Minimum system requirements for ShareCover

We're committed to providing our customers with the best products and services by utilising the latest available technology. For this reason, and to ensure smooth and safe use of your personal and payment information we have minimum browser requirements you'll need to use ShareCover:

Compatible Browsers

Google Chrome (version 58 and above)
FireFox (Latest version plus one previous version)
Safari (Latest version plus one previous version)
Internet Explorer (version 11.0 and above)

To find out how to update your browser to the latest version, please click here.

Mobile Devices

ShareCover is designed to be responsive and mobile compatible to allow you to work in the full version of the site on the go. You can purchase policies, update payment details, download policy documents, view and edit your policies, and more.

When working on a mobile device, the ShareCover site will resize and adjust.

Compatible mobile browsers

iOS: Safari
Android: Chrome

To note: In some cases, browser add-ons, extensions, or plugins can interfere with the functionality of the ShareCover site. If you're seeing any unexpected error or site behavior, you may want to disable these extras or try a browser without them to see if things improve.